Description:

Easy to use color getter.

Syntax:
public static Result GetColor(
string prompt,
bool acceptNothing,
ref Color color
)
Parameters:
  • prompt
  • Type: string
  • Command prompt.
  • acceptNothing
  • Type: bool
  • If true, the user can press enter.
  • color
  • Type: Color
  • Color value returned here. also used as default color.
Returns:
Type: Result
Commands.Result.Success - got color. Commands.Result.Nothing - user pressed enter. Commands.Result.Cancel - user cancel color getting.
Remarks:
If you need options or more advanced user interface, then use GetColor class.
Available since:
5.0

GetColor method

Class:  Rhino.Input.RhinoGet

Nothing found