Description:

Convert some arbitrary string value to a valid command option name removing any invalid characters.

Syntax:
public static LocalizeStringPair StringToCommandOptionName(
string englishString,
string localizedString
)
Parameters:
  • englishString
  • Type: string
  • English string to convert.
  • localizedString
  • Type: string
  • Optional localized string to convert.
Returns:
Returns None if the strings are None or empty or if they contain nothing but invalid characters. If the converted string is one or more characters in length then a <b>LocalizeStringPair</b> is returned characters the converted string values. If the localized string is None or empty then the English string is used as the localized value.
Available since:
6.0

Description:

Convert some arbitrary string value to a valid command option name removing any invalid characters.

Syntax:
public static string StringToCommandOptionName(
string stringToConvert
)
Parameters:
  • stringToConvert
  • Type: string
  • String to convert.
Returns:
Type: string
Returns None if the string is None or empty or if it contains nothing but invalid characters. If the converted string is one or more characters in length then the converted value is returned.
Available since:
6.0

/
/
/
StringToCommandOptionName

StringToCommandOptionName method

Class:  Rhino.Input.RhinoGet

Nothing found