Description:

Gets a point coordinate from the document.

Syntax:
public static Result GetPoint(
string prompt,
bool acceptNothing,
out Point3d point
)
Parameters:
  • prompt
  • Type: string
  • Prompt to display in command line during the operation.
  • acceptNothing
  • Type: bool
  • if true, the user can press enter.
  • point
  • Type: Point3d
  • point value returned here.
Returns:
Type: Result
Commands.Result.Success - got point Commands.Result.Nothing - user pressed enter Commands.Result.Cancel - user cancel point getting.
Remarks:
If you need options or more advanced user interface, then use GetPoint class.
Available since:
5.0

GetPoint method

Class:  Rhino.Input.RhinoGet

Nothing found