Description:

Easy to use Boolean getter.

Syntax:
public static Result GetBool(
string prompt,
bool acceptNothing,
string offPrompt,
string onPrompt,
ref bool boolValue
)
Parameters:
  • prompt
  • Type: string
  • Command prompt.
  • acceptNothing
  • Type: bool
  • If true, the user can press enter.
  • offPrompt
  • Type: string
  • The 'false/off' message.
  • onPrompt
  • Type: string
  • The 'true/on' message.
  • boolValue
  • Type: bool
  • Default Boolean value set to this and returned here.
Returns:
Type: Result
The getter result based on user choice. Commands.Result.Success - got value. Commands.Result.Nothing - user pressed enter. Commands.Result.Cancel - user canceled value getting.
Available since:
5.0

GetBool method

Class:  Rhino.Input.RhinoGet

Nothing found