Description:

Asks the user to select a Box in the viewport.

Syntax:
public static Result GetBox(
out Box box,
GetBoxMode mode,
Point3d basePoint,
string prompt1,
string prompt2,
string prompt3
)
Parameters:
  • box
  • Type: Box
  • If the result is Success, this parameter will be filled out.
  • mode
  • Type: GetBoxMode
  • A particular "get box" mode, or GetBoxMode.All .
  • basePoint
  • Type: Point3d
  • Optional base point. Supply Point3d.Unset if you don't want to use this.
  • prompt1
  • Type: string
  • Optional first prompt. Supply None to use the default prompt.
  • prompt2
  • Type: string
  • Optional second prompt. Supply None to use the default prompt.
  • prompt3
  • Type: string
  • Optional third prompt. Supply None to use the default prompt.
Returns:
Type: Result
Commands.Result.Success if successful.
Available since:
5.0

Description:

Asks the user to select a Box in the viewport.

Syntax:
public static Result GetBox(
out Box box
)
Parameters:
  • box
  • Type: Box
  • If the result is Success, this parameter will be filled out.
Returns:
Type: Result
Commands.Result.Success if successful.
Available since:
5.0

GetBox method

Class:  Rhino.Input.RhinoGet

Nothing found