Description:

Easy to use number getter.

Syntax:
public static Result GetNumber(
string prompt,
bool acceptNothing,
ref double outputNumber,
double lowerLimit,
double upperLimit
)
Parameters:
  • prompt
  • Type: string
  • The command prompt.
  • acceptNothing
  • Type: bool
  • If true, the user can press Enter.
  • outputNumber
  • Type: double
  • Default number is set to this value and the return number value is assigned to this variable during the call.
  • lowerLimit
  • Type: double
  • The minimum allowed value.
  • upperLimit
  • Type: double
  • The maximum allowed value.
Returns:
Type: Result
Commands.Result.Success - got number. Commands.Result.Nothing - user pressed enter. Commands.Result.Cancel - user cancel number getting.
Available since:
5.0

Description:

Easy to use number getter.

Syntax:
public static Result GetNumber(
string prompt,
bool acceptNothing,
ref double outputNumber
)
Parameters:
  • prompt
  • Type: string
  • command prompt.
  • acceptNothing
  • Type: bool
  • if true, the user can press enter.
  • outputNumber
  • Type: double
  • default number is set to this value and number value returned here.
Returns:
Type: Result
Commands.Result.Success - got number Commands.Result.Nothing - user pressed enter Commands.Result.Cancel - user cancel number getting.
Available since:
5.0

Nothing found