Description:
Gets a point constrained to an existing mesh in the document.
Syntax:
public static Result GetPointOnMesh(
MeshObject meshObject,
string prompt,
bool acceptNothing,
out Point3d point
)
MeshObject meshObject,
string prompt,
bool acceptNothing,
out Point3d point
)
deprecated in 7.6
obsolete: Use version that takes a document.
Parameters:
- meshObject
- Type: MeshObject
- An mesh object in the document.
- prompt
- Type: string
- Text prompt.
- acceptNothing
- Type: bool
- True if nothing else should be accepted.
- point
- Type: Point3d
- A point value will be assigned to this out parameter during this call.
Returns:
Type: Result
The command result based on user choice.
Available since:
5.0
Description:
Gets a point constrained to an existing mesh in the document.
Parameters:
- doc
- Type: RhinoDoc
- The Rhino document
- meshObject
- Type: MeshObject
- An mesh object in the document.
- prompt
- Type: string
- Text prompt.
- acceptNothing
- Type: bool
- True if nothing else should be accepted.
- point
- Type: Point3d
- A point value will be assigned to this out parameter during this call.
Returns:
Type: Result
The command result based on user choice.
Available since:
7.6
Description:
Gets a point constrained to an existing mesh in the document.
Parameters:
- doc
- Type: RhinoDoc
- Document containing mesh object.
- meshObjectId
- Type: System.Guid
- An ID of a mesh in the document.
- prompt
- Type: string
- Text prompt.
- acceptNothing
- Type: bool
- True if nothing else should be accepted.
- point
- Type: Point3d
- A point value will be assigned to this out parameter during this call.
Returns:
Type: Result
A command result based on user choice.
Available since:
7.6
Description:
Gets a point constrained to an existing mesh in the document.
deprecated in 7.6
obsolete: Use method that requires document
Parameters:
- meshObjectId
- Type: System.Guid
- An ID of a mesh in the document.
- prompt
- Type: string
- Text prompt.
- acceptNothing
- Type: bool
- True if nothing else should be accepted.
- point
- Type: Point3d
- A point value will be assigned to this out parameter during this call.
Returns:
Type: Result
A command result based on user choice.
Available since:
5.0