Description:

Gets a 3d rectangle made up of four points.

Syntax:
public static Result GetRectangle(
GetBoxMode mode,
Point3d firstPoint,
IEnumerable<string> prompts,
out Point3d[] corners
)
Parameters:
  • firstPoint
  • Type: Point3d
  • The first corner used. Pass Point3d.Unset if you do not want to set this.
  • prompts
  • Type: IEnumerable<string>
  • Optional prompts to display while getting points. May be null.
  • corners
  • Type: Point3d[]
  • Corners of the rectangle in counter-clockwise order will be assigned to this out parameter during this call.
Returns:
Type: Result
Commands.Result.Success if successful.
Available since:
5.0

Description:

Gets a 3d rectangle.

Syntax:
public static Result GetRectangle(
out Point3d[] corners
)
Parameters:
  • corners
  • Type: Point3d[]
  • corners of the rectangle in counter-clockwise order.
Returns:
Type: Result
Commands.Result.Success if successful.
Available since:
5.0

Description:

Gets a 3d rectangle.

Syntax:
public static Result GetRectangle(
string firstPrompt,
out Point3d[] corners
)
Parameters:
  • corners
  • Type: Point3d[]
  • corners of the rectangle in counter-clockwise order.
Returns:
Type: Result
Commands.Result.Success if successful.
Available since:
6.0

GetRectangle method

Class:  Rhino.Input.RhinoGet

Nothing found