Click or drag to resize

GH_FormatFormatInstanceReferenceValidity Method

If the instance reference is invalid, return a string describing why.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static string FormatInstanceReferenceValidity(
	InstanceReferenceGeometry val,
	string identifier = "Instance Reference"
)

Parameters

val
Type: InstanceReferenceGeometry
Value to format.
identifier (Optional)
Type: SystemString
Name used to refer to the value in the format.

Return Value

Type: String
A string describing why the instance reference is invalid or String.Empty if the value is not invalid.
See Also