Click or drag to resize

GH_FormatFormatLightValidity Method

If the light is invalid, return a string describing why.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static string FormatLightValidity(
	Light val,
	string identifier = "Light"
)

Parameters

val
Type: Light
Value to format.
identifier (Optional)
Type: SystemString
Name used to refer to the value in the format.

Return Value

Type: String
A string describing why the light is invalid or String.Empty if the value is not invalid.
See Also