Click or drag to resize

GH_FormatFormatIntervalValidity Method

If the point is invalid, return a string describing why.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static string FormatIntervalValidity(
	Interval val,
	string identifier = "Domain",
	bool testSingleton = false,
	bool testDecreasing = false
)

Parameters

val
Type: Interval
Value to format.
identifier (Optional)
Type: SystemString
Name used to refer to the value in the format.
testSingleton (Optional)
Type: SystemBoolean
If true, Intervals that have no length are considered invalid.
testDecreasing (Optional)
Type: SystemBoolean
If true, Intervals that are decreasing are considered invalid.

Return Value

Type: String
A string describing why the point is invalid or String.Empty if the value is not invalid.
See Also