Click or drag to resize

GH_FormatFormatSurfaceValidity Method

If the surface is invalid, return a string describing why.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static string FormatSurfaceValidity(
	Surface val,
	string identifier = "Surface"
)

Parameters

val
Type: Surface
Value to format.
identifier (Optional)
Type: SystemString
Name used to refer to the value in the format.

Return Value

Type: String
A string describing why the surface is invalid or String.Empty if the value is not invalid.
See Also