Click or drag to resize

GH_FormatFormatPlaneValidity Method

If the plane is invalid, return a string describing why.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static string FormatPlaneValidity(
	Plane val,
	string identifier = "Plane",
	bool testUnitAxes = false
)

Parameters

val
Type: Plane
Value to format.
identifier (Optional)
Type: SystemString
Name used to refer to the value in the format.
testUnitAxes (Optional)
Type: SystemBoolean
If True, planes with non-unit axis vectors are considered to be invalid.

Return Value

Type: String
A string describing why the plane is invalid or String.Empty if the value is not invalid.
See Also