Click or drag to resize

GH_FormatFormatComplexValidity Method

If the complex number is invalid, return a string describing why.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public static string FormatComplexValidity(
	Complex val,
	string identifier = "Complex"
)

Parameters

val
Type: Grasshopper.Kernel.TypesComplex
Value to format.
identifier (Optional)
Type: SystemString
Name used to refer to the value in the format.

Return Value

Type: String
A string describing why the complex number is invalid or String.Empty if the value is not invalid.
See Also