Description:

Adds a new layer with default definition to the layer table.

Syntax:
public int Add()
Returns:
Type: int
index of new layer.
Available since:
5.0

Description:

Adds a new layer with specified definition to the layer table.

Syntax:
public int Add(
Layer layer
)
Parameters:
  • layer
  • Type: Layer
  • definition of new layer. The information in layer is copied. If layer.Name is empty the a unique name of the form "Layer 01" will be automatically created.
Returns:
Type: int
>=0 index of new layer -1 layer not added because a layer with that name already exists.
Available since:
5.0

Description:

Adds a new layer with specified definition to the layer table.

Syntax:
public int Add(
string layerName,
Color layerColor
)
Parameters:
  • layerName
  • Type: string
  • Name for new layer. Cannot be a None or zero-length string.
  • layerColor
  • Type: System.Drawing.Color
  • Color of new layer. Alpha components will be ignored.
Returns:
Type: int
>=0 index of new layer -1 layer not added because a layer with that name already exists.
Available since:
5.0

Nothing found