Description:

Restores the layer to its previous state, if the layer has been modified and the modification can be undone.

Syntax:
public bool UndoModify(
int layerIndex,
uint undoRecordSerialNumber
)
Parameters:
  • layerIndex
  • Type: int
  • The layer index to be used.
  • undoRecordSerialNumber
  • Type: uint
  • The undo record serial number. Pass 0 not to specify one.
Returns:
Type: bool
True if this layer had been modified and the modifications were undone.
Available since:
5.0

Description:

Restores the layer to its previous state, if the layer has been modified and the modification can be undone.

Syntax:
public bool UndoModify(
int layerIndex
)
Parameters:
  • layerIndex
  • Type: int
  • The layer index to be used.
Returns:
Type: bool
True if this layer had been modified and the modifications were undone.
Available since:
5.0

Description:

Restores the layer to its previous state, if the layer has been modified and the modification can be undone.

Syntax:
public bool UndoModify(
Guid layerId,
uint undoRecordSerialNumber
)
Parameters:
  • layerId
  • Type: System.Guid
  • The layer Id to be used.
  • undoRecordSerialNumber
  • Type: uint
  • The undo record serial number. Pass 0 not to specify one.
Returns:
Type: bool
True if this layer had been modified and the modifications were undone.
Available since:
6.0

Description:

Restores the layer to its previous state, if the layer has been modified and the modification can be undone.

Syntax:
public bool UndoModify(
Guid layerId
)
Parameters:
  • layerId
  • Type: System.Guid
  • The layer Id to be used.
Returns:
Type: bool
True if this layer had been modified and the modifications were undone.
Available since:
6.0

Nothing found