Description:

Gets the next unused layer name used as default when creating new layers.

Syntax:
public string GetUnusedLayerName()
Returns:
Type: string
An unused layer name string.
Available since:
6.0

Description:

Gets the next unused layer name used as default when creating new layers.

Syntax:
public string GetUnusedLayerName(
bool ignoreDeleted
)
deprecated in 6.0
obsolete: 'ignoreDeleted' is now redundant. Layers are now permanently removed. Use the overload with this argument.
Parameters:
  • ignoreDeleted
  • Type: bool
  • If this is True then Rhino may use a name used by a deleted layer.
Returns:
Type: string
An unused layer name string.
Available since:
5.0

Nothing found