Description:

Duplicates, or copies, one or more layers. Duplicated layers are added to the document.

Syntax:
public int Duplicate(
IEnumerable<int> layerIndices,
bool duplicateObjects,
bool duplicateSublayers
)
Parameters:
  • layerIndices
  • Type: IEnumerable<int>
  • The indices of layers to duplicate.
  • duplicateObjects
  • Type: bool
  • If true, then layer objects will also be duplicated and added to the document.
  • duplicateSublayers
  • Type: bool
  • If true, then all sub-layers of the layer will be duplicated.
Returns:
Type: int
The indices of the newly added layers if successful, an empty array on failure.
Available since:
6.18

Description:

Duplicates, or copies, a layer. Duplicated layers are added to the document.

Syntax:
public int Duplicate(
int layerIndex,
bool duplicateObjects,
bool duplicateSublayers
)
Parameters:
  • layerIndex
  • Type: int
  • The index of the layer to duplicate.
  • duplicateObjects
  • Type: bool
  • If true, then layer objects will also be duplicated and added to the document.
  • duplicateSublayers
  • Type: bool
  • If true, then all sub-layers of the layer will be duplicated.
Returns:
Type: int
The indices of the newly added layers if successful, an empty array on failure.
Available since:
6.18

Nothing found