Description:

Modifies layer settings.

Syntax:
public bool Modify(
Layer newSettings,
int layerIndex,
bool quiet
)
Parameters:
  • newSettings
  • Type: Layer
  • This information is copied.
  • layerIndex
  • Type: int
  • zero based index of layer to set. This must be in the range 0 <= layerIndex < LayerTable.Count.
  • quiet
  • Type: bool
  • if false, information message boxes pop up when illegal changes are attempted.
Returns:
Type: bool
True if successful. False if layerIndex is out of range or the settings attempt to lock or hide the current layer.
Available since:
5.0

Description:

Modifies layer settings.

Syntax:
public bool Modify(
Layer newSettings,
Guid layerId,
bool quiet
)
Parameters:
  • newSettings
  • Type: Layer
  • This information is copied.
  • layerId
  • Type: System.Guid
  • Id of layer.
  • quiet
  • Type: bool
  • if false, information message boxes pop up when illegal changes are attempted.
Returns:
Type: bool
True if successful. False if layerIndex is out of range or the settings attempt to lock or hide the current layer.
Available since:
6.0

Nothing found