Description:

Deletes a layer and all geometry objects on a layer

Syntax:
public bool Purge(
int layerIndex,
bool quiet
)
Parameters:
  • layerIndex
  • Type: int
  • zero based index of layer to delete. This must be in the range 0 <= layerIndex < LayerTable.Count.
  • quiet
  • Type: bool
  • If true, no warning message box appears if a layer the layer cannot be deleted because it is the current layer.
Returns:
Type: bool
True if successful. False if layerIndex is out of range or the layer cannot be deleted because it is the current layer.
Available since:
5.5

Description:

Deletes a layer and all geometry objects on a layer.

Syntax:
public bool Purge(
Guid layerId,
bool quiet
)
Parameters:
  • layerId
  • Type: System.Guid
  • Id of the layer to purge.
  • quiet
  • Type: bool
  • If true, no warning message box appears if a layer the layer cannot be deleted because it is the current layer.
Returns:
Type: bool
True if successful. False if layerIndex is out of range or the layer cannot be deleted because it is the current layer.
Available since:
6.0

Nothing found