Description:

At all times, there is a "current" layer. Unless otherwise specified, new objects are assigned to the current layer. The current layer is never locked, hidden, or deleted.

Syntax:
public bool SetCurrentLayerIndex(
int layerIndex,
bool quiet
)
Parameters:
  • layerIndex
  • Type: int
  • Value for new current layer. 0 <= layerIndex < LayerTable.Count. The layer's mode is automatically set to NormalMode.
  • quiet
  • Type: bool
  • if true, then no warning message box pops up if the current layer request can't be satisfied.
Returns:
Type: bool
True if current layer index successfully set.
Available since:
5.0

SetCurrentLayerIndex method

Class:  Rhino.DocObjects.Tables.LayerTable

Nothing found