Description:

Adds a new reference layer with default definition to the layer table. Reference layers are not saved in files.

Syntax:
public int AddReferenceLayer()
Returns:
Type: int
index of new layer.
Available since:
5.0

Description:

Adds a new reference layer with specified definition to the layer table Reference layers are not saved in files.

Syntax:
public int AddReferenceLayer(
Layer layer
)
Parameters:
  • layer
  • Type: Layer
  • definition of new layer. The information in layer is copied. If layer.Name is empty the a unique name of the form "Layer 01" will be automatically created.
Returns:
Type: int
>=0 index of new layer -1 layer not added because a layer with that name already exists.
Available since:
5.0

AddReferenceLayer method

Class:  Rhino.DocObjects.Tables.LayerTable

Nothing found