Description:

Adds all of the layer in the specified layer path, beginning with the root. Layer paths contain one or more valid layers names, with each name separated by ModelComponent.NamePathSeparator . For example, "Grandfather::Father::Son".

Syntax:
public int AddPath(
string layerPath,
Color layerColor
)
Parameters:
  • layerPath
  • Type: string
  • The layer path.
  • layerColor
  • Type: System.Drawing.Color
  • The color of newly created layers. The colors of layers that already exist will not be changed.
Returns:
Type: int
The index of the last layer created if successful, <b>RhinoMath.UnsetIntIndex</b> on failure.
Available since:
8.0

Description:

Adds all of the layer in the specified layer path, beginning with the root. Layer paths contain one or more valid layers names, with each name separated by ModelComponent.NamePathSeparator . For example, "Grandfather::Father::Son".

Syntax:
public int AddPath(
string layerPath
)
Parameters:
  • layerPath
  • Type: string
  • The layer path.
Returns:
Type: int
The index of the last layer created if successful, <b>RhinoMath.UnsetIntIndex</b> on failure.
Available since:
8.0

Nothing found