Description:
Syntax:
public int FindByFullPath(
string layerPath,
bool ignoreDeletedLayers
)
deprecated in 6.0
obsolete: ignoreDeletedLayers is no longer supported for research by name. Use the overload with notFoundReturnValue
Returns:
Type: int
Available since:
5.0

Description:

Searches for a layer using the fully qualified name, that includes ancestors. Deleted layers have no name.

Syntax:
public int FindByFullPath(
string layerPath,
int notFoundReturnValue
)
Parameters:
  • layerPath
  • Type: string
  • The full layer name.
  • notFoundReturnValue
  • Type: int
  • Should be -1 to get the index of the OpenNURBS default layer, or RhinoMath.UnsetIntIndex to get an always-out-of-bound value.
Returns:
Type: int
The index of the found layer, or notFoundReturnValue.
Available since:
6.0

FindByFullPath method

Class:  Rhino.DocObjects.Tables.LayerTable

Nothing found