Description:

Finds the next layer that has an index equal or higher than the searched value. Search in case-insensitive.

Syntax:
public Layer FindName(
string layerName,
int startIndex
)
Parameters:
  • layerName
  • Type: string
  • The layer to search for.
  • startIndex
  • Type: int
  • If you specify RhinoMath.UnsetIntIndex, then also default layers will be included. This is the first index that will be tested.
Returns:
Type: Layer
A layer, or null.
Available since:
6.0

Description:

Finds the layer with a given name. If multiple layers exist that have the same name, the first match layer index will be returned. Deleted layers have no name. The default layer is NOT included in the search. If required, use the overload with startIndex input.

Syntax:
public Layer FindName(
string layerName
)
Parameters:
  • layerName
  • Type: string
  • name of layer to search for. The search ignores case.
Returns:
Type: Layer
A layer, or null.
Available since:
6.0

Nothing found