What's New?

RhinoScript 6

New Methods

Method

Description

AddCircleTanTan

Adds a circle curve that is tangent to 2 curves to the document.

AddCircleTanTanTan

Adds a circle curve that is tangent to 3 curves to the document.

AddTextOutlines

Adds outline curves created from a text string to the document.

BlockIds

Returns the identifiers of all block definitions in the document.

BlockInstanceId

Returns the block definition identifier of a block instance object.

BlockName

Returns the name of a block definition given the block definition's identifier.

BlockType

Returns the definition, or update, type of a block.

ChangeCurveDegree

Changes the degree of a curve object.

ChangeSurfaceDegree

Changes the degree of a surface object.

CircleCircleIntersection

Intersects two coplanar circles.

CleanUpPolyCurve

Cleans up a polycurve.

ClippingPlaneView

Returns or modifies the clipped views of a clipping plane object.

CurveExtremePoints

Returns the point locations of all local extrema.

CurveFilletCorners

Rounds the corners of kinked curves with arcs of a single specified radius.

CurvePerpPoint

Finds the location on a curve that is perpendicular to a test point.

CurveTangentPoint

Finds the location on a curve that is tangent to a test point.

EnableModelSpaceHatchScale

Enables or disables model space hatch scaling.

EnableModelSpaceTextScale

Enables or disables model space text scaling.

FilletSurfacesEx

Creates a surface between two surfaces and adds it to the document.

FilterObjects

Filters an array of object identifiers.

GetAsyncKeyState

Determines whether a key is up or down at the time the function is called.

GetKey

Pauses for user input of a keyboard key.

GetSystemMetrics

Retrieves the specified system metric or system configuration setting.

IntersectStrings

Returns the intersection of two string arrays.

MergeSurfaces

Merges two surfaces into one surface at untrimmed edges.

MeshPatch

Creates a polygon mesh from curves and points.

FMod

Returns the floating-point remainder.

IsCurveConicSection

Tests a curve to see if it is a conic section.

IsFullScreen

Verifies that Rhino is running in full screen mode.

ModelSpaceHatchScale

Returns or modifies the model space hatch scale factor.

ModelSpaceLinetypeScale

Returns or modifies the model space linetype scale factor.

ModelSpaceTextScale

Returns or modifies the model space text scale factor.

Named Position Methods

Methods related to named object positions.

ObjectCastsShadows

Returns or modifies an object's casts shadows property.

ObjectDataCRC

Returns the CRC value of an object's data, or geometry.

ObjectReceivesShadows

Returns or modifies an object's receives shadows property.

ObjectSerialNumber

Returns the unique serial number of an object.

ObjectSpace

Returns the active working space of an object.

PlaySound

Plays a sound specified by the given file name.

PromptMessage

Set the text that appears in the Rhino command prompt.

RecentFiles

Returns a list of recently opened Rhino models.

Rnd

Returns a random number.

SelectedLayers

Returns the layers that are selected in Rhino's layer UI.

SelectLayers

Selects layers in Rhino's layer UI.

SetCursorPos

Moves the cursor to the specified screen coordinates.

SmoothCurve

Smooths a curve object.

SmoothMesh

Smooths a mesh object.

SmoothSurface

Smooths a surface object.

SoftEditCurve

Soft edits a curve object.

SoftEditSurface

Soft edits a surface object.

SplitSurfaceEx

Splits a surface into pieces using trimming curves.

SurfaceDivideAlongCreases

Divides a surface or polysurface into separate parts at kinks or tangents.

TextObjectMask

Returns or set the mask of a text object.

UnionStrings

Returns the union of two string arrays.

ViewDisplayModeProperty

Returns or modifies the property of a display mode.

Changed Methods

Method

Changes

ArcAngle

Additional, optional, tolerance argument added.

ArcCenterPoint

Additional, optional, tolerance argument added.

ArcMidPoint

Additional, optional, tolerance argument added.

ArcRadius

Additional, optional, tolerance argument added.

BooleanDifference

Additional, optional argument added.

BooleanIntersection

Additional, optional argument added.

BooleanUnion

Additional, optional argument added.

CheckListBox

Additional, optional, position argument added.

CircleCenterPoint

Additional, optional, tolerance argument added.

CircleCircumference

Additional, optional, tolerance argument added.

CircleRadius

Additional, optional, tolerance argument added.

ComboListBox

Additional, optional, position argument added.

CurveDiscontinuity

Additional, optional, angle tolerance argument added.

DeleteObject

Additional, optional argument added.

DeleteObjects

Additional, optional argument added.

EditBox

Additional, optional, position argument added.

EditListBox

Additional, optional, position argument added.

IntegerBox

Additional, optional, position argument added.

IsArc

Additional, optional, tolerance argument added.

IsCircle

Additional, optional, tolerance argument added.

IsVectorParallelTo

Additional, optional, tolerance argument added.

IsVectorPerpendicularTo

Additional, optional, tolerance argument added.

ListBox

Additional, optional, position argument added.

MirrorObject

Additional, optional, plane argument added.

MirrorObjects

Additional, optional, plane argument added.

MultiListBox

Additional, optional, position argument added.

ObjectsByColor

Additional, optional argument added.

ObjectsByGroup

Additional, optional argument added.

ObjectsByLayer

Additional, optional argument added.

ObjectsByMaterialIndex

Additional, optional argument added.

ObjectsByMaterialSource

Additional, optional argument added.

ObjectsByName

Additional, optional argument added.

ObjectsByURL

Additional, optional argument added.

OrderListBox

Additional, optional, position argument added.

PointPick

Additional, optional arguments added.

PropertyListBox

Additional, optional, position argument added.

RealBox

Additional, optional, position argument added.

StringBox

Additional, optional, position argument added.

SurfaceArea

Additional, optional, index argument added.

SurfaceAreaCentroid

Additional, optional, index argument added.

SurfaceAreaMoments

Additional, optional, index argument added.

UnrollSurface

Additional, optional, arguments added.