GH_TaskCapableComponentT Methods |
The GH_TaskCapableComponentT generic type exposes the following members.
Name | Description | |
---|---|---|
AddRuntimeMessage |
Add a new message to this object. Valid message type flags are Warning and Error.
BeforeSolveInstance |
Override this method if you want to be called
CollectData |
Calls CollectData on all input parameters and makes sure the
DestroyIconCache |
Call this method to erase the existing icon cache.
ExpirePreview |
Call this function when you suspect that the preview has expired for this object.
ExpireSolution |
Informs the document that owns this object that the solution has expired.
The current object will be set to BLANK as a result. This method is recursive,
it will also expire any and all objects which depend on this object.
If you want a less destructive expiration, consider using ClearData().
GetSolveResults |
Call this method to await the associated task and retrieve its data.
HtmlHelp_Source |
Return a String which contains HTML formatted source for the help topic.
If you want to pass a URL that points to a remote page, then prefix the URL with a GOTO: tag, like so:
Menu_AppendObjectName |
Appends the old-fashioned object name menu item. If you also want the
Menu_AppendPublish |
Appends the default item for publishing to RCP.
NewInstanceGuid(Guid) |
Set the instance ID to be a specific GUID. This is very dangerous, only use this function
OnPingDocument |
Raise the PingDocument Event on the toplevel object and try to find
OnSolutionExpired |
Raises the SolutionExpired event on the toplevel object.
RequestTaskCancellation |
Called by the framework when solving has been interrupted and tasks do not
need to complete.
SolveInstance |
This function will be called (successively) from within the
ValuesChanged |
Override this method if you want to respond to changes to the value table.