Description:

Sets another ArchivableDictionary as entry in this dictionary.

Syntax:
Parameters:
  • val
  • Type: ArchivableDictionary
  • An object for that key. Because this class is a reference type and is mutable, changes to this object will propagate to the object inside the dictionary. It is up to the user to clone this entry when appropriate.
Returns:
Type: bool
Available since:
5.0

Description:

Sets a bool .

Syntax:
public bool Set(
string key,
bool val
)
Parameters:
  • val
  • Type: bool
  • A bool value. Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
True if set operation succeeded, otherwise false.
Available since:
5.0

Description:

Sets a byte .

Syntax:
public bool Set(
string key,
byte val
)
Parameters:
  • val
  • Type: byte
  • A byte . Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
True if set operation succeeded, otherwise false.
Available since:
5.0

Description:

Sets a Rhino.DocObjects.ObjRef

Syntax:
public bool Set(
string key,
ObjRef val
)
Parameters:
  • val
  • Type: DocObjects.ObjRef
  • An object for that key Because this class is a reference type and is mutable, changes to this object will propagate to the object inside the dictionary. It is up to the user to clone this entry when appropriate.
Returns:
Type: bool
Available since:
5.8

Description:

Sets a double .

Syntax:
public bool Set(
string key,
double val
)
Parameters:
  • val
  • Type: double
  • A double . Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
True if set operation succeeded, otherwise false.
Available since:
5.0

Description:

Sets a float .

Syntax:
public bool Set(
string key,
float val
)
Parameters:
  • val
  • Type: float
  • A float . Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
True if set operation succeeded, otherwise false.
Available since:
5.0

Description:

Sets a Rhino.Geometry.BoundingBox .

Syntax:
public bool Set(
string key,
BoundingBox val
)
Parameters:
  • val
  • Type: Geometry.BoundingBox
  • A value for that key. Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
Available since:
5.0

Description:

Sets any class deriving from the Rhino.Geometry.GeometryBase base class.

Syntax:
public bool Set(
string key,
GeometryBase val
)
Parameters:
  • val
  • Type: Geometry.GeometryBase
  • A geometry object for that key. Because this class is a reference type and is mutable, changes to this object will propagate to the object inside the dictionary. It is up to the user to clone this entry when appropriate. You can use for this.
Returns:
Type: bool
Available since:
5.0

Description:

Sets an Rhino.Geometry.Interval .

Syntax:
public bool Set(
string key,
Interval val
)
Parameters:
  • val
  • Type: Geometry.Interval
  • A value for that key. Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
Available since:
5.0

Description:

Sets a Rhino.Geometry.Line .

Syntax:
public bool Set(
string key,
Line val
)
Parameters:
  • val
  • Type: Geometry.Line
  • A value for that key. Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
Available since:
5.0

Description:

Sets a Rhino.Geometry.MeshingParameters .

Syntax:
public bool Set(
string key,
MeshingParameters val
)
Parameters:
  • val
  • Type: Geometry.MeshingParameters
  • An object for that key. Because this class is a reference type and is mutable, changes to this object will propagate to the object inside the dictionary. It is up to the user to clone this entry when appropriate.
Returns:
Type: bool
Available since:
5.0

Description:

Sets a Rhino.Geometry.Plane .

Syntax:
public bool Set(
string key,
Plane val
)
Parameters:
  • val
  • Type: Geometry.Plane
  • A plane for that key. Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
Available since:
5.0

Description:

Sets a Rhino.Geometry.Point2d .

Syntax:
public bool Set(
string key,
Point2d val
)
Parameters:
  • val
  • Type: Geometry.Point2d
  • A point for that key. Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
Available since:
5.0

Description:

Sets a Rhino.Geometry.Point3d .

Syntax:
public bool Set(
string key,
Point3d val
)
Parameters:
  • val
  • Type: Geometry.Point3d
  • A point for that key. Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
Available since:
5.0

Description:

Sets a Rhino.Geometry.Point3f .

Syntax:
public bool Set(
string key,
Point3f val
)
Parameters:
  • val
  • Type: Geometry.Point3f
  • A value for that key. Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
Available since:
5.0

Description:

Sets a Rhino.Geometry.Point4d .

Syntax:
public bool Set(
string key,
Point4d val
)
Parameters:
  • val
  • Type: Geometry.Point4d
  • A value for that key. Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
Available since:
5.0

Description:

Sets a Rhino.Geometry.Ray3d .

Syntax:
public bool Set(
string key,
Ray3d val
)
Parameters:
  • val
  • Type: Geometry.Ray3d
  • A value for that key. Because has value semantics and is immutable, no changes to this object are possible.
Returns:
Type: bool
Available since:
5.0

Description:

Sets a Rhino.Geometry.Transform .

Syntax:
public bool Set(
string key,
Transform val
)
Parameters:
  • val
  • Type: Geometry.Transform
  • A transform for that key. Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
Available since:
5.0

Description:

Sets a Rhino.Geometry.Vector2d .

Syntax:
public bool Set(
string key,
Vector2d val
)
Parameters:
  • val
  • Type: Geometry.Vector2d
  • A value for that key. Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
Available since:
5.0

Description:

Sets a Rhino.Geometry.Vector3d .

Syntax:
public bool Set(
string key,
Vector3d val
)
Parameters:
  • val
  • Type: Geometry.Vector3d
  • A value for that key. Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
Available since:
5.0

Description:

Sets a Rhino.Geometry.Vector3f .

Syntax:
public bool Set(
string key,
Vector3f val
)
Parameters:
  • val
  • Type: Geometry.Vector3f
  • A value for that key. Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
Available since:
5.0

Description:

Sets a list, an array or any enumerable of bool .

Syntax:
public bool Set(
string key,
IEnumerable<bool> val
)
Parameters:
  • val
  • Type: IEnumerable<bool>
  • A value for that key. Because this interface is a reference type, changes to the assigned object will modify this entry inside the dictionary. It is up to the user to clone this entry when appropriate.
Returns:
Type: bool
True if set operation succeeded, otherwise false.
Available since:
5.0

Description:

Sets a list, an array or any enumerable of byte .

Syntax:
public bool Set(
string key,
IEnumerable<byte> val
)
Parameters:
  • val
  • Type: IEnumerable<byte>
  • A value for that key Because this interface is a reference type, changes to the assigned object will modify this entry inside the dictionary. It is up to the user to clone this entry when appropriate.
Returns:
Type: bool
True if set operation succeeded, otherwise false.
Available since:
5.0

Description:

Sets a list, an array or any enumerable of double .

Syntax:
public bool Set(
string key,
IEnumerable<double> val
)
Parameters:
  • val
  • Type: IEnumerable<double>
  • A value for that key. Because this interface is a reference type, changes to the assigned object will modify this entry inside the dictionary. It is up to the user to clone this entry when appropriate.
Returns:
Type: bool
True if set operation succeeded, otherwise false.
Available since:
5.0

Description:

Sets a list, an array or any enumerable of float .

Syntax:
public bool Set(
string key,
IEnumerable<float> val
)
Parameters:
  • val
  • Type: IEnumerable<float>
  • A value for that key. Because this interface is a reference type, changes to the assigned object will modify this entry inside the dictionary. It is up to the user to clone this entry when appropriate.
Returns:
Type: bool
True if set operation succeeded, otherwise false.
Available since:
5.0

Description:

Sets an array of Rhino.Geometry.GeometryBase

Syntax:
public bool Set(
string key,
IEnumerable<GeometryBase> val
)
Parameters:
  • val
  • Type: IEnumerable<Geometry.GeometryBase>
  • An object for that key Because this class is a reference type and is mutable, changes to this object will propagate to the object inside the dictionary. It is up to the user to clone this entry when appropriate.
Returns:
Type: bool
True if successful, False otherwise.
Available since:
7.0

Description:

Sets a list, an array or any enumerable of Guid .

Syntax:
public bool Set(
string key,
IEnumerable<Guid> val
)
Parameters:
  • val
  • Type: IEnumerable<Guid>
  • A value for that key. Because this interface is a reference type, changes to the assigned object will modify this entry inside the dictionary. It is up to the user to clone this entry when appropriate.
Returns:
Type: bool
True if set operation succeeded, otherwise false.
Available since:
5.0

Description:

Sets a list, an array or any enumerable of int .

Syntax:
public bool Set(
string key,
IEnumerable<int> val
)
Parameters:
  • val
  • Type: IEnumerable<int>
  • A value for that key. Because this interface is a reference type, changes to the assigned object will modify this entry inside the dictionary. It is up to the user to clone this entry when appropriate.
Returns:
Type: bool
True if set operation succeeded, otherwise false.
Available since:
5.0

Description:

Sets an array of Rhino.DocObjects.ObjRef

Syntax:
public bool Set(
string key,
IEnumerable<ObjRef> val
)
Parameters:
  • val
  • Type: IEnumerable<DocObjects.ObjRef>
  • An object for that key Because this class is a reference type and is mutable, changes to this object will propagate to the object inside the dictionary. It is up to the user to clone this entry when appropriate.
Returns:
Type: bool
Available since:
5.8

Description:

Sets a list, an array or any enumerable of sbyte .

Syntax:
public bool Set(
string key,
IEnumerable<sbyte> val
)
Parameters:
  • val
  • Type: IEnumerable<sbyte>
  • A value for that key. Because this interface is a reference type, changes to the assigned object will modify this entry inside the dictionary. It is up to the user to clone this entry when appropriate.
Returns:
Type: bool
True if set operation succeeded, otherwise false.
Available since:
5.0

Description:

Sets a list, an array or any enumerable of short .

Syntax:
public bool Set(
string key,
IEnumerable<short> val
)
Parameters:
  • val
  • Type: IEnumerable<short>
  • A value for that key. Because this interface is a reference type, changes to the assigned object will modify this entry inside the dictionary. It is up to the user to clone this entry when appropriate.
Returns:
Type: bool
True if set operation succeeded, otherwise false.
Available since:
5.0

Description:

Sets a list, an array or any enumerable of string .

Syntax:
public bool Set(
string key,
IEnumerable<string> val
)
Parameters:
  • val
  • Type: IEnumerable<string>
  • A value for that key. Because this interface is a reference type, changes to the assigned object will modify this entry inside the dictionary. It is up to the user to clone this entry when appropriate.
Returns:
Type: bool
True if set operation succeeded, otherwise false.
Available since:
5.0

Description:

Sets a int .

Syntax:
public bool Set(
string key,
int val
)
Parameters:
  • val
  • Type: int
  • A int . Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
True if set operation succeeded, otherwise false.
Available since:
5.0

Description:

Sets a sbyte .

Syntax:
public bool Set(
string key,
sbyte val
)
Parameters:
  • val
  • Type: sbyte
  • A sbyte . Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
True if set operation succeeded, otherwise false.
Available since:
5.0

Description:

Sets a short .

Syntax:
public bool Set(
string key,
short val
)
Parameters:
  • val
  • Type: short
  • A short . Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
True if set operation succeeded, otherwise false.
Available since:
5.0

Description:

Sets a string .

Syntax:
public bool Set(
string key,
string val
)
Parameters:
  • val
  • Type: string
  • A string . Because is immutable, it is not possible to modify the object while it is in this dictionary.
Returns:
Type: bool
True if set operation succeeded, otherwise false.
Available since:
5.0

Description:

Sets a System.Drawing.Color .

Syntax:
public bool Set(
string key,
Color val
)
Parameters:
  • val
  • Type: System.Drawing.Color
  • A value for that key. Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
True if set operation succeeded, otherwise false.
Available since:
5.0

Description:

Sets a System.Drawing.Font .

Syntax:
public bool Set(
string key,
Font val
)
Parameters:
  • val
  • Type: System.Drawing.Font
  • A value for that key. Because is immutable, it is not possible to modify the object while it is in this dictionary.
Returns:
Type: bool
Available since:
5.0

Description:

Sets a System.Drawing.Point .

Syntax:
public bool Set(
string key,
Point val
)
Parameters:
  • val
  • Type: System.Drawing.Point
  • A value for that key. Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
Available since:
5.0

Description:

Sets a System.Drawing.PointF .

Syntax:
public bool Set(
string key,
PointF val
)
Parameters:
  • val
  • Type: System.Drawing.PointF
  • A value for that key. Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
Available since:
5.0

Description:

Sets a System.Drawing.Rectangle .

Syntax:
public bool Set(
string key,
Rectangle val
)
Parameters:
  • val
  • Type: System.Drawing.Rectangle
  • A value for that key. Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
Available since:
5.0

Description:

Sets a System.Drawing.RectangleF .

Syntax:
public bool Set(
string key,
RectangleF val
)
Parameters:
  • val
  • Type: System.Drawing.RectangleF
  • A value for that key. Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
Available since:
5.0

Description:

Sets a System.Drawing.Size .

Syntax:
public bool Set(
string key,
Size val
)
Parameters:
  • val
  • Type: System.Drawing.Size
  • A value for that key. Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
Available since:
5.0

Description:

Sets a System.Drawing.SizeF .

Syntax:
public bool Set(
string key,
SizeF val
)
Parameters:
  • val
  • Type: System.Drawing.SizeF
  • A value for that key. Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
Available since:
5.0

Description:

Sets a Guid .

Syntax:
public bool Set(
string key,
Guid val
)
Parameters:
  • val
  • Type: System.Guid
  • A Guid . Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
True if set operation succeeded, otherwise false.
Available since:
5.0

Description:

Sets a long .

Syntax:
public bool Set(
string key,
Int64 val
)
Parameters:
  • val
  • Type: System.Int64
  • A long . Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
True if set operation succeeded, otherwise false.
Available since:
5.0

Description:

Sets a uint .

Syntax:
public bool Set(
string key,
uint val
)
Parameters:
  • val
  • Type: uint
  • A uint . Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
True if set operation succeeded, otherwise false.
Available since:
5.0

Description:

Sets a ushort .

Syntax:
public bool Set(
string key,
ushort val
)
Parameters:
  • val
  • Type: ushort
  • A ushort . Because has value semantics, changes to the assigning value will leave this entry unchanged.
Returns:
Type: bool
True if set operation succeeded, otherwise false.
Available since:
5.0

Nothing found