Description:

Override this function if you want to extend the document properties sections of the options dialog. This function is called whenever the user brings up the Options dialog.

Syntax:
protected virtual void DocumentPropertiesDialogPages(
RhinoDoc doc,
List<OptionsDialogPage> pages
)
protected
virtual
Parameters:
  • doc
  • Type: RhinoDoc
  • document that the pages are set up for
  • pages
  • Type: List<OptionsDialogPage>
  • list of pages to add your custom options dialog page(s) to.
Returns:
Type: void

/
/
/
DocumentPropertiesDialogPages

DocumentPropertiesDialogPages method

Class:  Rhino.PlugIns.PlugIn

Nothing found