Description:

Verifies that there is a valid product license for your plug-in, using the Rhino licensing system. If the plug-in is installed as a standalone node, the locally installed license will be validated. If the plug-in is installed as a network node, a loaner license will be requested by the system's assigned Zoo server. If the Zoo server finds and returns a license, then this license will be validated. If no license is found, then the user will be prompted to provide a license key, which will be validated.

Syntax:
protected bool GetLicense(
LicenseBuildType productBuildType,
ValidateProductKeyDelegate validateProductKeyDelegate,
OnLeaseChangedDelegate leaseChangedDelegate
)
protected
Parameters:
  • productBuildType
  • Type: LicenseBuildType
  • The product build contentType required by your plug-in.
  • validateProductKeyDelegate
  • Type: ValidateProductKeyDelegate
  • Since the Rhino licensing system knows nothing about your product license, you will need to validate the product license provided by the Rhino licensing system. This is done by supplying a callback function, or delegate, that can be called to perform the validation.
Returns:
Type: bool
True if a valid license was found. False otherwise.

Description:

Verifies that there is a valid product license for your plug-in, using the Rhino licensing system. If the plug-in is installed as a standalone node, the locally installed license will be validated. If the plug-in is installed as a network node, a loaner license will be requested by the system's assigned Zoo server. If the Zoo server finds and returns a license, then this license will be validated. If no license is found, then the user will be prompted to provide a license key, which will be validated.

Syntax:
protected bool GetLicense(
LicenseCapabilities licenseCapabilities,
string textMask,
ValidateProductKeyDelegate validateProductKeyDelegate,
OnLeaseChangedDelegate leaseChangedDelegate
)
protected
Parameters:
  • licenseCapabilities
  • Type: LicenseCapabilities
  • In the event that a license was not found, or if the user wants to change the way your plug-in is licenses, then provide what capabilities your license has by using this enumeration flag.
  • textMask
  • Type: string
  • In the event that the user needs to be asked for a license, then you can provide a text mask, which helps the user to distinguish between proper and improper user input of your license code. Note, if you do not want to use a text mask, then pass in a None value for this parameter. For more information on text masks, search MSDN for the System.Windows.Forms.MaskedTextBox class.
  • validateProductKeyDelegate
  • Type: ValidateProductKeyDelegate
  • Since the Rhino licensing system knows nothing about your product license, you will need to validate the product license provided by the Rhino licensing system. This is done by supplying a callback function, or delegate, that can be called to perform the validation.
Returns:
Type: bool
True if a valid license was found. False otherwise.

GetLicense method

Class:  Rhino.PlugIns.PlugIn

Nothing found