Description:

Attempt to load a plug-in at a path. Loaded plug-ins are remembered by Rhino between sessions, so this function can also be considered a plug-in installation routine

Syntax:
public static LoadPlugInResult LoadPlugIn(
string path,
out Guid plugInId
)
Parameters:
  • path
  • Type: string
  • full path to plug-in to attempt to load
  • plugInId
  • Type: System.Guid
  • If successful (or the plug-in is already loaded), the unique id for the plug-in is returned here. Guid.Empty on failure
Returns:
Available since:
6.0

Description:

Loads an installed plug-in.

Syntax:
public static bool LoadPlugIn(
Guid pluginId,
bool loadQuietly,
bool forceLoad
)
Parameters:
  • pluginId
  • Type: System.Guid
  • The id of the installed plug-in.
  • loadQuietly
  • Type: bool
  • Load the plug-in quietly.
  • forceLoad
  • Type: bool
  • Load plug-in even if previous attempt to load has failed.
Returns:
Type: bool
True if successful, False otherwise.
Available since:
6.0

Description:

Loads an installed plug-in.

Syntax:
public static bool LoadPlugIn(
Guid pluginId
)
Parameters:
  • pluginId
  • Type: System.Guid
  • The id of the installed plug-in.
Returns:
Type: bool
True if successful, False otherwise.
Available since:
5.0

LoadPlugIn method

Class:  Rhino.PlugIns.PlugIn

Nothing found