Description:

Called whenever a Rhino is about to save a .3dm file. If you want to save plug-in document data when a model is saved in a version 5 .3dm file, then you must override this function to return True and you must override WriteDocument().

Syntax:
protected virtual bool ShouldCallWriteDocument(
FileWriteOptions options
)
protected
virtual
Parameters:
  • options
  • Type: FileIO.FileWriteOptions
  • The file write options, such as "include preview image" and "include render meshes".
Returns:
Type: bool
True if the plug-in wants to save document user data in the version 5 .3dm file. The default returns false.

/
/
/
ShouldCallWriteDocument

ShouldCallWriteDocument method

Class:  Rhino.PlugIns.PlugIn

Nothing found