Description:

Called when Rhino is saving a .3dm file to allow the plug-in to save document user data.

Syntax:
protected virtual void WriteDocument(
RhinoDoc doc,
BinaryArchiveWriter archive,
FileWriteOptions options
)
protected
virtual
Parameters:
  • doc
  • Type: RhinoDoc
  • The Rhino document instance that is being saved.
  • archive
  • Type: FileIO.BinaryArchiveWriter
  • OpenNURBS file archive object Rhino is using to write the file. Use BinaryArchiveWriter.Write*() functions to write plug-in data. OR use the ArchivableDictionary If any BinaryArchiveWriter.Write*() functions throw an exception, then archive.WriteErrorOccured will be True and you should immediately return. Setting archive.WriteErrorOccured to True will cause Rhino to stop saving the file.
  • options
  • Type: FileIO.FileWriteOptions
  • The file write options, such as "include preview image" and "include render meshes".
Returns:
Type: void

/
/
/
WriteDocument

WriteDocument method

Class:  Rhino.PlugIns.PlugIn

Nothing found