Description:

Joins adjacent triangles into quads if the resulting quad is 'nice'.

Syntax:
public bool ConvertTrianglesToQuads(
double angleToleranceRadians,
double minimumDiagonalLengthRatio
)
Parameters:
  • angleToleranceRadians
  • Type: double
  • Used to compare adjacent triangles' face normals. For two triangles to be considered, the angle between their face normals has to be <= angleToleranceRadians. When in doubt use RhinoMath.PI/90.0 (2 degrees).
  • minimumDiagonalLengthRatio
  • Type: double
  • ( <= 1.0) For two triangles to be considered the ratio of the resulting quad's diagonals (length of the shortest diagonal)/(length of longest diagonal). has to be >= minimumDiagonalLengthRatio. When in doubt us .875.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

ConvertTrianglesToQuads method

Class:  Rhino.Geometry.Collections.MeshFaceList

Nothing found