Description:

Find all connected face indices where adjacent face normals meet the criteria of angleRadians and greaterThanAngle

Syntax:
public int GetConnectedFaces(
int faceIndex,
double angleRadians,
bool greaterThanAngle
)
Parameters:
  • faceIndex
  • Type: int
  • face index to start from
  • angleRadians
  • Type: double
  • angle to use for comparison of what is connected
  • greaterThanAngle
  • Type: bool
  • If True angles greater than or equal to are considered connected. If false, angles less than or equal to are considered connected.
Returns:
Type: int
list of connected face indices
Available since:
5.6

Description:

Find all connected face indices

Syntax:
public int GetConnectedFaces(
int faceIndex
)
Parameters:
  • faceIndex
  • Type: int
  • face index to start from
Returns:
Type: int
list of connected face indices
Available since:
7.1

GetConnectedFaces method

Class:  Rhino.Geometry.Collections.MeshFaceList

Nothing found