Description:

Copies all of the faces to a linear array of indices. Clean-up of vertex indices if replacedIndices is a valid List

Syntax:
public int ToIntArray(
bool asTriangles,
ref List<int> replacedIndices
)
Parameters:
  • asTriangles
  • Type: bool
  • If set totrueas triangles.
  • replacedIndices
  • Type: List<int>
  • List is populated with vertex indices that were replaced with 0. If replacedIndices is None there will be no cleanup
Returns:
Type: int
The int array. This method never returns null.

Description:

Copies all of the face indices to a linear array of indices per face. Note that this includes indices from invalid faces too.

Syntax:
public int ToIntArray(
bool asTriangles
)
Parameters:
  • asTriangles
  • Type: bool
  • If set totrueas triangles.
Returns:
Type: int
The int array. This method never returns null.
Available since:
5.9

Nothing found