Description:

Uses startFaceIndex and finds all connected face indexes up to unwelded or naked edges. If treatNonmanifoldLikeUnwelded is True then non-manifold edges will be considered as unwelded or naked

Syntax:
public int GetConnectedFacesToEdges(
int startFaceIndex,
bool treatNonmanifoldLikeUnwelded
)
Parameters:
  • startFaceIndex
  • Type: int
  • Initial face index
  • treatNonmanifoldLikeUnwelded
  • Type: bool
  • True means non-manifold edges will be handled like unwelded edges, False means they aren't considered
Returns:
Type: int
Array of connected face indexes
Available since:
5.6

GetConnectedFacesToEdges method

Class:  Rhino.Geometry.Collections.MeshFaceList

Nothing found