Description:

Examines and adds face indexes to whollyDegenerateFaces if the face is a triangle with zero area or a quad both triangles have zero area. Face indexes are added to partiallyDegenerateFaces when a quad has one triangle with zero area.

Syntax:
public bool GetZeroAreaFaces(
out int whollyDegenerateFaces,
out int partiallyDegenerateFaces
)
Parameters:
  • whollyDegenerateFaces
  • Type: int
  • Array of indexes for faces, both triangles and quads, that have zero area.
  • partiallyDegenerateFaces
  • Type: int
  • Array of indexes for quad faces, that have one triangle with zero area.
Returns:
Type: bool
Returns True if the mesh has wholly or partially degenerate faces, False otherwise.
Available since:
6.0

Nothing found