Description:

Breaks this polyline into sections at sharp kinks. Closed polylines will also be broken at the first and last vertex.

Syntax:
public Polyline[] BreakAtAngles(
double angle
)
Parameters:
  • angle
  • Type: double
  • Angle (in radians) between adjacent segments for a break to occur.
Returns:
An array of polyline segments, or None on error.
Available since:
5.0

BreakAtAngles method

Class:  Rhino.Geometry.Polyline

Nothing found