Description:

Collapses all segments until none are shorter than tolerance. This function is significantly slower than DeleteShortSegments, since it recursively operates on the shortest segment. When a segment is collapsed the end-points are placed in the center of the segment.

Syntax:
public int CollapseShortSegments(
double tolerance
)
Parameters:
  • tolerance
  • Type: double
  • Tolerance to use during collapsing.
Returns:
Type: int
The number of segments that were collapsed.
Available since:
5.0

/
/
/
CollapseShortSegments

CollapseShortSegments method

Class:  Rhino.Geometry.Polyline

Nothing found