Description:

Merge co-linear consecutive segments in a polyline. This method will automatically remove any zero-length segments as well.

Syntax:
public int MergeColinearSegments(
double angleTolerance,
bool includeSeam
)
Parameters:
  • angleTolerance
  • Type: double
  • The angle tolerance between adjacent segments for collinearity test.
  • includeSeam
  • Type: bool
  • If true, the seam point of a closed polyline will be moved forwards if it is collinear too.
Returns:
Type: int
Number of segments removed from the entire polyline.
Available since:
6.3

/
/
/
MergeColinearSegments

MergeColinearSegments method

Class:  Rhino.Geometry.Polyline

Nothing found