Description:

Create a regular star polygon. The star begins at circle.PointAt(0) and the vertices alternate between being on circle and begin on a concentric circle of other_radius.

Syntax:
public static Polyline CreateStarPolygon(
Circle circle,
double radius,
int cornerCount
)
Parameters:
  • radius
  • Type: double
  • The radius of other circle.
  • cornerCount
  • Type: int
  • The number of corners on the circle. There will be 2*cornerCount sides and 2*cornerCount vertices.
Returns:
Type: Polyline
A closed polyline if successful, None otherwise.
Available since:
6.10

/
/
/
CreateStarPolygon

CreateStarPolygon method

Class:  Rhino.Geometry.Polyline

Nothing found