Description:
Syntax:
Description:
Add a new .NET control to an content expandable tab section, the height of the createExpanded tabs client area will be the initial height of the specified control.
Syntax:
public UserInterfaceSection AddUserInterfaceSection(
Type classType,
string caption,
bool createExpanded,
bool createVisible
)
Type classType,
string caption,
bool createExpanded,
bool createVisible
)
deprecated in 6.0
Parameters:
- classType
- Type: System.Type
- The control class to create and embed as a child window in the expandable tab client area. This class type must be derived from IWin32Window or this method will throw an ArgumentException. Implement the IUserInterfaceSection interface in your classType to get UserInterfaceSection notification.
- caption
- Type: string
- Expandable tab caption.
- createExpanded
- Type: bool
- If this value is True then the new expandable tab section will initially be expanded, if it is False it will be collapsed.
- createVisible
- Type: bool
- If this value is True then the new expandable tab section will initially be visible, if it is False it will be hidden.
Returns:
Type: UserInterfaceSection
Returns the UserInterfaceSection object used to manage the new user control object.
Available since:
5.1