Description:

As RenderHash, but allows you to specify flags and exclude specific parameters. Use this version of the function to calculate a render hash when you have the linear workflow information and you are not running on the main thread. Access to LinearWorkflow data requires document access. CrcRenderHashFlags.ExcludeLinearWorkflow must be specified.

Syntax:
public uint RenderHashExclude(
CrcRenderHashFlags flags,
string excludeParameterNames,
LinearWorkflow lw
)
Parameters:
  • excludeParameterNames
  • Type: string
  • Semicolon-delimited string of parameter names to exclude.
Returns:
Type: uint
The render hash.
Available since:
6.2

Description:

As RenderHash, but allows you to specify flags and exclude specific parameters.

Syntax:
public uint RenderHashExclude(
CrcRenderHashFlags flags,
string excludeParameterNames
)
Parameters:
  • excludeParameterNames
  • Type: string
  • Semicolon-delimited string of parameter names to exclude.
Returns:
Type: uint
The render hash.
Available since:
6.2

Description:

This method is deprecated in favor of the one that takes CrcRenderHashFlags.

Syntax:
public uint RenderHashExclude(
TextureRenderHashFlags flags,
string excludeParameterNames
)
deprecated in 8.0
Returns:
Type: uint
Available since:
6.0

/
/
/
RenderHashExclude

RenderHashExclude method

Class:  Rhino.Render.RenderContent

Nothing found