Description:
Allows the user to choose a content by displaying the Content Instance Browser dialog. The dialog will have OK, Cancel and Help buttons, and optional New and Edit buttons. Specifies the document to use.Sets the initially selected content and receives the instance id of the chosen content.Specifies the kind(s) of content that should be displayed in the browser.Specifies which optional buttons to display. Returns True if the user chooses a content or False if the dialog is cancelled.
Syntax:
public static bool ShowContentInstanceBrowser(
RhinoDoc doc,
ref Guid instance_id,
RenderContentKind kinds,
ContentInstanceBrowserButtons buttons
)
RhinoDoc doc,
ref Guid instance_id,
RenderContentKind kinds,
ContentInstanceBrowserButtons buttons
)
Parameters:
- doc
- Type: RhinoDoc
- Specifies the document to use.
- instance_id
- Type: System.Guid
- Sets the initially selected content and receives the instance id of the chosen content.
- kinds
- Type: RenderContentKind
- Specifies the kind(s) of content that should be displayed in the browser.
- buttons
- Type: ContentInstanceBrowserButtons
- Specifies which optional buttons to display.
Returns:
Type: bool