Description:

Begins a change or batch of changes. It may also make a copy of the content state allowing EndChange to send an event with the old and new contents. Calls to this method are counted; you must call EndChange() once for every call to BeginChange(). Note: If Changed() was called between the calls to BeginChange() and EndChange(), the last call to EndChange() may cause the ContentChanged event to be sent.

Syntax:
public void BeginChange(
ChangeContexts changeContext
)
Parameters:
  • changeContext
  • Type: ChangeContexts
  • the change context. If this is ChangeContexts.UI, ChangeContexts.Program,ChangeContexts.Drop or ChangeContexts.Tree, the content will be copied. EndChange() will then send the copy as 'old' in the OnContentChanged event. EndChange ContentChanged
Returns:
Type: void
Available since:
6.0

BeginChange method

Class:  Rhino.Render.RenderContent

Nothing found