Description:

Constructs a new content of the specified type and attaches it to a document. This function cannot be used to create temporary content that you delete after use. Content created by this function is owned by RDK and appears in the content editor. To create a temporary content which is owned by you, call RenderContentType.NewContentFromTypeId().

Syntax:
public static RenderContent Create(
RhinoDoc doc,
Guid type,
RenderContent parent,
string childSlotName
)
Parameters:
  • doc
  • Type: RhinoDoc
  • The Rhino document to attach the new render content to.
  • type
  • Type: System.Guid
  • The type of the content to create.
  • parent
  • Type: RenderContent
  • Parent is the parent content. If not null, this must be an RDK-owned content that is attached to the document (either top-level or child). The new content then becomes its child. If null, the new content is added to the top-level document content list instead.
  • childSlotName
  • Type: string
  • ChildSlotName is the unique child identifier to use for the new content when creating it as a child of parent (i.e., when parent is not null)
Returns:
A new document-resident render content.
Available since:
7.9

Description:

Constructs a new content of the specified type and attaches it to a document. This function cannot be used to create temporary content that you delete after use. Content created by this function is owned by RDK and appears in the content editor. To create a temporary content which is owned by you, call RenderContentType.NewContentFromTypeId().

Syntax:
public static RenderContent Create(
RhinoDoc doc,
Guid type
)
Parameters:
  • doc
  • Type: RhinoDoc
  • The Rhino document to attach the new render content to.
  • type
  • Type: System.Guid
  • The type of the content to create.
Returns:
A new document-resident render content.
Available since:
7.9

Description:

Constructs a new content of the specified type and attaches it to a document. This function cannot be used to create temporary content that you delete after use. Content created by this function is owned by RDK and appears in the content editor. To create a temporary content which is owned by you, call RenderContentType.NewContentFromTypeId().

Syntax:
public static RenderContent Create(
RhinoDoc doc,
Type type,
RenderContent parent,
string childSlotName
)
Parameters:
  • doc
  • Type: RhinoDoc
  • The Rhino document to attach the new render content to.
  • type
  • Type: System.Type
  • The type of the content to create.
  • parent
  • Type: RenderContent
  • The parent content. If not null, this must be an RDK-owned content that is attached to the document (either top-level or child). The new content then becomes its child. If null, the new content is added to the top-level document content list instead.
  • childSlotName
  • Type: string
  • ChildSlotName is the unique child identifier to use for the new content when creating it as a child of parent (i.e., when parent is not null)
Returns:
A new document-resident render content.
Available since:
7.9

Description:

Constructs a new content of the specified type and attaches it to a document. This function cannot be used to create temporary content that you delete after use. Content created by this function is owned by RDK and appears in the content editor. To create a temporary content which is owned by you, call RenderContentType.NewContentFromTypeId().

Syntax:
public static RenderContent Create(
RhinoDoc doc,
Type type
)
Parameters:
  • doc
  • Type: RhinoDoc
  • The Rhino document to attach the new render content to.
  • type
  • Type: System.Type
  • The type of the content to create.
Returns:
A new document-resident render content.
Available since:
7.9

Description:

Constructs a new content of the specified type and attaches it to a document. This function cannot be used to create temporary content that you delete after use. Content created by this function is owned by RDK and appears in the content editor. To create a temporary content which is owned by you, call RenderContentType.NewContentFromTypeId().

Syntax:
public static RenderContent Create(
Guid type,
RenderContent parent,
String childSlotName,
ShowContentChooserFlags flags,
RhinoDoc doc
)
deprecated in 7.9
Parameters:
  • type
  • Type: System.Guid
  • The type of the content to create.
  • parent
  • Type: RenderContent
  • Parent is the parent content. If not null, this must be an RDK-owned content that is attached to the document (either top-level or child). The new content then becomes its child. If null, the new content is added to the top-level document content list instead.
  • childSlotName
  • Type: System.String
  • ChildSlotName is the unique child identifier to use for the new content when creating it as a child of parent (i.e., when parent is not null)
  • doc
  • Type: RhinoDoc
  • The Rhino document to attach the new render content to.
Returns:
A new document-resident render content.
Available since:
5.1

Description:

Constructs a new content of the specified type and attaches it to a document. This function cannot be used to create temporary content that you delete after use. Content created by this function is owned by RDK and appears in the content editor. To create a temporary content which is owned by you, call RenderContentType.NewContentFromTypeId().

Syntax:
public static RenderContent Create(
Guid type,
ShowContentChooserFlags flags,
RhinoDoc doc
)
deprecated in 7.9
Parameters:
  • type
  • Type: System.Guid
  • The type of the content to create.
  • doc
  • Type: RhinoDoc
  • The Rhino document to attach the new render content to.
Returns:
A new document-resident render content.
Available since:
5.1

Description:

Constructs a new content of the specified type and attaches it to a document. This function cannot be used to create temporary content that you delete after use. Content created by this function is owned by RDK and appears in the content editor. To create a temporary content which is owned by you, call RenderContentType.NewContentFromTypeId().

Syntax:
public static RenderContent Create(
Type type,
RenderContent parent,
String childSlotName,
ShowContentChooserFlags flags,
RhinoDoc doc
)
deprecated in 7.9
Parameters:
  • type
  • Type: System.Type
  • The type of the content to create.
  • parent
  • Type: RenderContent
  • The parent content. If not null, this must be an RDK-owned content that is attached to the document (either top-level or child). The new content then becomes its child. If null, the new content is added to the top-level document content list instead.
  • childSlotName
  • Type: System.String
  • ChildSlotName is the unique child identifier to use for the new content when creating it as a child of parent (i.e., when parent is not null)
  • doc
  • Type: RhinoDoc
  • The Rhino document to attach the new render content to.
Returns:
A new document-resident render content.
Available since:
5.1

Description:

Constructs a new content of the specified type and attaches it to a document. This function cannot be used to create temporary content that you delete after use. Content created by this function is owned by RDK and appears in the content editor. To create a temporary content which is owned by you, call RenderContentType.NewContentFromTypeId().

Syntax:
public static RenderContent Create(
Type type,
ShowContentChooserFlags flags,
RhinoDoc doc
)
deprecated in 7.9
Parameters:
  • type
  • Type: System.Type
  • The type of the content to create.
  • doc
  • Type: RhinoDoc
  • The Rhino document to attach the new render content to.
Returns:
A new document-resident render content.
Available since:
5.1

Nothing found