Description:
Syntax:
public virtual bool IsFactoryProductAcceptableAsChild(
ContentFactory factory,
String childSlotName
)
virtual
Returns:
Type: bool
Available since:
6.1

Description:

Override this method to restrict the type of acceptable child content. The default implementation of this method returns True if the factory kind is 'texture'.

Syntax:
virtual public bool IsFactoryProductAcceptableAsChild(
Guid kindId,
string factoryKind,
string childSlotName
)
virtual
Returns:
Type: bool
Return True only if content with the specified kindId can be accepted as a child in the specified child slot.
Available since:
5.11

/
/
/
IsFactoryProductAcceptableAsChild

IsFactoryProductAcceptableAsChild method

Class:  Rhino.Render.RenderContent

Nothing found