Click or drag to resize

GH_DocumentBoundingBox Method

Returns the boundingbox of all the normal attributes. If the document contains no normal attributes an Empty RectangleF structure is returned.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public RectangleF BoundingBox(
	bool limitToSelection = false
)

Parameters

limitToSelection (Optional)
Type: SystemBoolean
If true, only selected attributes are included in the boundingbox computation.

Return Value

Type: RectangleF
The boundingbox of the requested objects or RectangleF.Empty if no objects could be found.
See Also