Click or drag to resize

GH_DocumentSolutionProgress Method

Returns the progress of the current solution.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public int SolutionProgress(
	out int objectIndex,
	out int maximumIndex
)

Parameters

objectIndex
Type: SystemInt32
The index of the object currently being solved.
maximumIndex
Type: SystemInt32
The highest index.

Return Value

Type: Int32
Percentage of solution as a number between 1 and 99 inclusive.
See Also